aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorLane Kolbly <lane.kolbly@ni.com>2020-06-22 18:06:38 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-06-25 13:36:08 -0500
commitd6cb55ef08f51c9ebef57e5bbcb95b03a65972a9 (patch)
tree8b8f1350d9d45d513f00e2b8e836a52600d27e66 /host/lib/CMakeLists.txt
parente9ae5fb949903cce1720b75b894401930cce1ebe (diff)
downloaduhd-d6cb55ef08f51c9ebef57e5bbcb95b03a65972a9.tar.gz
uhd-d6cb55ef08f51c9ebef57e5bbcb95b03a65972a9.tar.bz2
uhd-d6cb55ef08f51c9ebef57e5bbcb95b03a65972a9.zip
uhd: Create discoverable feature registry implementation
Classes which want to implement discoverable_feature can simply inherit from this registry and get access to an ergonomic map-backed registry of features.
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index c5046420a..c0b39faea 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -83,6 +83,7 @@ LIBUHD_REGISTER_COMPONENT("DPDK" ENABLE_DPDK ON "ENABLE_MPMD;DPDK_FOUND" OFF OFF
########################################################################
INCLUDE_SUBDIRECTORY(include)
INCLUDE_SUBDIRECTORY(cal)
+INCLUDE_SUBDIRECTORY(features)
INCLUDE_SUBDIRECTORY(ic_reg_maps)
INCLUDE_SUBDIRECTORY(types)
INCLUDE_SUBDIRECTORY(convert)