aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorLuca Boccassi <bluca@debian.org>2022-01-14 14:13:19 +0000
committerAaron Rossetto <aaron.rossetto@ni.com>2022-01-20 13:58:51 -0600
commitb1586ee26b61fedd74e3bc076f7ff58d7a72f615 (patch)
tree1ab09a06308acee12f2136e13e91246111fb9d87 /host/lib/CMakeLists.txt
parent4e391500b54a22dbaae8692750ec25ae8a97ee6d (diff)
downloaduhd-b1586ee26b61fedd74e3bc076f7ff58d7a72f615.tar.gz
uhd-b1586ee26b61fedd74e3bc076f7ff58d7a72f615.tar.bz2
uhd-b1586ee26b61fedd74e3bc076f7ff58d7a72f615.zip
host: fix build with DPDK v21.11 LTS
Some APIs were changed with the latest DPDK LTS release, add some ifdefs to fix the build. Fixes https://github.com/EttusResearch/uhd/issues/547 Updated CMake file to reflect updated DPDK version. Fixed mbuf size to take ethernet headers into account. Updated documentation. Co-authored-by: Martin Anderseck <martin.anderseck@ni.com>
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 00da8b75c..094827d2a 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -60,7 +60,7 @@ endmacro(INCLUDE_SUBDIRECTORY)
message(STATUS "")
# Dependencies
find_package(LIBUSB)
-find_package(DPDK 19.11...20.11)
+find_package(DPDK 19.11...21.11)
LIBUHD_REGISTER_COMPONENT("USB" ENABLE_USB ON "ENABLE_LIBUHD;LIBUSB_FOUND" OFF OFF)
# Devices
LIBUHD_REGISTER_COMPONENT("B100" ENABLE_B100 ON "ENABLE_LIBUHD;ENABLE_USB" OFF OFF)