aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-08-17 17:25:03 -0700
committerJosh Blum <josh@joshknows.com>2010-08-17 17:25:03 -0700
commit864de41af536de1a4e86aa4542e2cfeb21f2d309 (patch)
tree259f582fca4b73ea5db4811bf2423294b02477a3 /host/lib/CMakeLists.txt
parent0541029e4ecd06e840966b4005af316b92eeb9e5 (diff)
parent7d110e73e6b0651f73e8e5b165244f59e66fed87 (diff)
downloaduhd-864de41af536de1a4e86aa4542e2cfeb21f2d309.tar.gz
uhd-864de41af536de1a4e86aa4542e2cfeb21f2d309.tar.bz2
uhd-864de41af536de1a4e86aa4542e2cfeb21f2d309.zip
Merge branch 'next'
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 48cfe742e..cbb68c725 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -53,6 +53,15 @@ INCLUDE(${CMAKE_CURRENT_SOURCE_DIR}/utils/CMakeLists.txt)
########################################################################
# Append to the list of sources for lib uhd
########################################################################
+FILE(TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/${PKG_DATA_DIR} LOCAL_PKG_DATA_DIR)
+MESSAGE(STATUS "Local package data directory: ${LOCAL_PKG_DATA_DIR}")
+
+IF(UNIX)
+ #on unix systems, installers will use this directory for the package data
+ FILE(TO_NATIVE_PATH /usr/${PKG_DATA_DIR} INSTALLER_PKG_DATA_DIR)
+ MESSAGE(STATUS "Installer package data directory: ${INSTALLER_PKG_DATA_DIR}")
+ENDIF(UNIX)
+
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/constants.hpp.in
${CMAKE_CURRENT_BINARY_DIR}/constants.hpp