aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-06-09 22:42:47 -0700
committerMartin Braun <martin.braun@ettus.com>2018-06-11 12:13:46 -0700
commit526929071a43b820e6ee45961e0a10e605862e91 (patch)
tree182d6c879230e379474c5de5c8ff0142cf21a514 /host/lib/CMakeLists.txt
parente4f6565e5e0a979331f9d7847d93e78d1177c4f9 (diff)
downloaduhd-526929071a43b820e6ee45961e0a10e605862e91.tar.gz
uhd-526929071a43b820e6ee45961e0a10e605862e91.tar.bz2
uhd-526929071a43b820e6ee45961e0a10e605862e91.zip
cmake: Add ENABLE_N300 target
Driver support for N310/N300 was previously implied by ENABLE_MPMD, which had two issues: 1) It was not clear that ENABLE_MPMD was actually enabling the N3x0 2) It did not allow to enable mpmd support without N3x0 support This resolves these issues.
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 2c1422119..984f16f96 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -74,6 +74,7 @@ LIBUHD_REGISTER_COMPONENT("USRP2" ENABLE_USRP2 ON "ENABLE_LIBUHD" OFF OFF)
LIBUHD_REGISTER_COMPONENT("X300" ENABLE_X300 ON "ENABLE_LIBUHD" OFF OFF)
LIBUHD_REGISTER_COMPONENT("N230" ENABLE_N230 ON "ENABLE_LIBUHD" OFF OFF)
LIBUHD_REGISTER_COMPONENT("MPMD" ENABLE_MPMD ON "ENABLE_LIBUHD" OFF OFF)
+LIBUHD_REGISTER_COMPONENT("N300" ENABLE_N300 ON "ENABLE_LIBUHD;ENABLE_MPMD" OFF OFF)
LIBUHD_REGISTER_COMPONENT("OctoClock" ENABLE_OCTOCLOCK ON "ENABLE_LIBUHD" OFF OFF)
########################################################################