aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-08-09 11:24:08 -0700
committerJosh Blum <josh@joshknows.com>2010-08-09 11:24:08 -0700
commit2a87970a9ca5bf98c555ad216c551263663fedcc (patch)
tree2f53325cda0523d8d4d46b1e9fcc051995acad66 /host/lib/CMakeLists.txt
parentf159e4e367b897a7e2f675cdbb44e9b52b29b176 (diff)
downloaduhd-2a87970a9ca5bf98c555ad216c551263663fedcc.tar.gz
uhd-2a87970a9ca5bf98c555ad216c551263663fedcc.tar.bz2
uhd-2a87970a9ca5bf98c555ad216c551263663fedcc.zip
uhd: created library code to handle paths for images and modules
- read from environment variable paths - utility functions to get paths and search for images - modified load modules to call the utility functions - added private header constants.hpp to contain cmake variables of interest - modified version.cpp to use this constants file
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 25a2b168f..48cfe742e 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -54,14 +54,16 @@ INCLUDE(${CMAKE_CURRENT_SOURCE_DIR}/utils/CMakeLists.txt)
# Append to the list of sources for lib uhd
########################################################################
CONFIGURE_FILE(
- ${CMAKE_CURRENT_SOURCE_DIR}/version.cpp.in
- ${CMAKE_CURRENT_BINARY_DIR}/version.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/constants.hpp.in
+ ${CMAKE_CURRENT_BINARY_DIR}/constants.hpp
@ONLY)
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_BINARY_DIR}/constants.hpp
${CMAKE_CURRENT_SOURCE_DIR}/device.cpp
${CMAKE_CURRENT_SOURCE_DIR}/types.cpp
- ${CMAKE_CURRENT_BINARY_DIR}/version.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/version.cpp
${CMAKE_CURRENT_SOURCE_DIR}/wax.cpp
)