aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-19 18:08:20 -0800
committerJosh Blum <josh@joshknows.com>2010-03-19 18:08:20 -0800
commit26ada5ee709fc4d7e195d19720b467c14368bc05 (patch)
treefed7199054d8ae3860fb11499fb199a69ef9336a /host/lib/CMakeLists.txt
parent9c436f72cd065c172b04bcefcca71e80591059c6 (diff)
downloaduhd-26ada5ee709fc4d7e195d19720b467c14368bc05.tar.gz
uhd-26ada5ee709fc4d7e195d19720b467c14368bc05.tar.bz2
uhd-26ada5ee709fc4d7e195d19720b467c14368bc05.zip
added install path for dll, fixed idiotic msvc error where making a vector with proxies crashes the app, seems to be ok with the sptr fix, in other good news, discover usrps works in my vm for the usrp2
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 8e6bd693c..875a065af 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -64,6 +64,7 @@ TARGET_LINK_LIBRARIES(uhd ${Boost_LIBRARIES})
SET_TARGET_PROPERTIES(uhd PROPERTIES DEFINE_SYMBOL "UHD_DLL_EXPORTS")
INSTALL(TARGETS uhd
- LIBRARY DESTINATION ${LIBRARY_DIR}
- ARCHIVE DESTINATION ${LIBRARY_DIR}
+ LIBRARY DESTINATION ${LIBRARY_DIR} # .so file
+ ARCHIVE DESTINATION ${LIBRARY_DIR} # .lib file
+ RUNTIME DESTINATION ${LIBRARY_DIR} # .dll file
)