aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2017-11-10 21:42:22 -0800
committerMartin Braun <martin.braun@ettus.com>2017-12-22 14:59:23 -0800
commitfc8cd827f6b16b9c8c354a216889e6a9d7f37456 (patch)
treea1adc8a55d72a4218c0119b0607970d98c3cce64 /host/lib/CMakeLists.txt
parent24eaccf7a552d10f243fc0fd095d422bd802368c (diff)
downloaduhd-fc8cd827f6b16b9c8c354a216889e6a9d7f37456.tar.gz
uhd-fc8cd827f6b16b9c8c354a216889e6a9d7f37456.tar.bz2
uhd-fc8cd827f6b16b9c8c354a216889e6a9d7f37456.zip
lib: Add non-public include directory
This is meant for headers that don't export symbols.
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 0219c082c..2679ce302 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -77,6 +77,7 @@ LIBUHD_REGISTER_COMPONENT("OctoClock" ENABLE_OCTOCLOCK ON "ENABLE_LIBUHD" OFF OF
########################################################################
# Include subdirectories (different than add)
########################################################################
+INCLUDE_SUBDIRECTORY(include)
INCLUDE_SUBDIRECTORY(ic_reg_maps)
INCLUDE_SUBDIRECTORY(types)
INCLUDE_SUBDIRECTORY(convert)