aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2015-12-18 12:17:53 -0800
committerMartin Braun <martin.braun@ettus.com>2015-12-30 14:23:05 -0800
commitf4656fcb7b4a60cb603ce90abac8266a7e47ec7f (patch)
tree3be67568b7a185ab9419a187a8ddbef26931857f /host/lib/CMakeLists.txt
parentdb9ebd80dd0d675b2018f1ac504745e9bd110cd9 (diff)
downloaduhd-f4656fcb7b4a60cb603ce90abac8266a7e47ec7f.tar.gz
uhd-f4656fcb7b4a60cb603ce90abac8266a7e47ec7f.tar.bz2
uhd-f4656fcb7b4a60cb603ce90abac8266a7e47ec7f.zip
Added uhd_config_info utility
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 07775895d..5fb75671d 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -95,6 +95,16 @@ INCLUDE_SUBDIRECTORY(usrp_clock)
INCLUDE_SUBDIRECTORY(utils)
########################################################################
+# Build info
+########################################################################
+INCLUDE(UHDBuildInfo)
+UHD_LOAD_BUILD_INFO()
+CONFIGURE_FILE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/build_info.cpp
+ ${CMAKE_CURRENT_BINARY_DIR}/build_info.cpp
+@ONLY)
+
+########################################################################
# Setup UHD_VERSION_STRING for version.cpp
########################################################################
CONFIGURE_FILE(
@@ -106,6 +116,7 @@ CONFIGURE_FILE(
# Append to the list of sources for lib uhd
########################################################################
LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_BINARY_DIR}/build_info.cpp
${CMAKE_CURRENT_SOURCE_DIR}/deprecated.cpp
${CMAKE_CURRENT_SOURCE_DIR}/device.cpp
${CMAKE_CURRENT_SOURCE_DIR}/image_loader.cpp