aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-03 11:28:32 -0800
committerJosh Blum <josh@joshknows.com>2010-03-03 11:28:32 -0800
commitccd2665a29af046b0b8a11c48ffbfe2ed36ce8d9 (patch)
tree0ebf3fda5a9f7f973872bd99bb62386d18c93941 /host/lib/CMakeLists.txt
parente531f936e6ffa645a944b360a51f82004c6cdfcb (diff)
downloaduhd-ccd2665a29af046b0b8a11c48ffbfe2ed36ce8d9.tar.gz
uhd-ccd2665a29af046b0b8a11c48ffbfe2ed36ce8d9.tar.bz2
uhd-ccd2665a29af046b0b8a11c48ffbfe2ed36ce8d9.zip
Split metadata into rx and tx specific metadata.
The rx metadata has fragment flags and the tx metatdata has burst flags. Made the io impl for usrp2 rx routine fill in the rx metatdata fragment flag. Added device documentation for send and recv in regards to fragmentation.
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 390349906..b1daf22d1 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -22,6 +22,7 @@ SET(libuhd_sources
device.cpp
device_addr.cpp
gain_handler.cpp
+ metadata.cpp
wax.cpp
transport/udp_simple.cpp
transport/vrt.cpp