aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2013-07-15 15:20:56 -0700
committerJosh Blum <josh@joshknows.com>2013-07-15 15:20:56 -0700
commita7153fecdb1416df03f21467c52dbb35cb675f6f (patch)
tree04473eaaa56aef63597d0daf937d451ebcc28fb6 /host/lib/CMakeLists.txt
parentead07058f1d6f24ed390081df83044099b171a85 (diff)
downloaduhd-a7153fecdb1416df03f21467c52dbb35cb675f6f.tar.gz
uhd-a7153fecdb1416df03f21467c52dbb35cb675f6f.tar.bz2
uhd-a7153fecdb1416df03f21467c52dbb35cb675f6f.zip
uhd: added virtual destructors for several interface classes
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index a37a8ab85..4ca06af9a 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright 2010-2011,2013 Ettus Research LLC
+# Copyright 2010-2013 Ettus Research LLC
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -88,6 +88,7 @@ CONFIGURE_FILE(
LIBUHD_APPEND_SOURCES(
${CMAKE_CURRENT_SOURCE_DIR}/deprecated.cpp
${CMAKE_CURRENT_SOURCE_DIR}/device.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/stream.cpp
${CMAKE_CURRENT_SOURCE_DIR}/exception.cpp
${CMAKE_CURRENT_SOURCE_DIR}/property_tree.cpp
${CMAKE_CURRENT_BINARY_DIR}/version.cpp