aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorCiro Nishiguchi <cironishiguchi@gmail.com>2018-08-21 13:41:43 -0500
committerBrent Stapleton <bstapleton@g.hmc.edu>2018-08-22 17:42:39 -0700
commit27a2182974869539c66a746a5f449d8ded0fb307 (patch)
tree54a26bf0bbb651844484ffa395881015f224295d /host/lib/CMakeLists.txt
parent3814e07606514a650b99e4909bd2fb1bdfadc2e2 (diff)
downloaduhd-27a2182974869539c66a746a5f449d8ded0fb307.tar.gz
uhd-27a2182974869539c66a746a5f449d8ded0fb307.tar.bz2
uhd-27a2182974869539c66a746a5f449d8ded0fb307.zip
uhd: Define UHD_API as empty string when building static lib
Fixes #2484 When building uhd host as a static library on Windows, UHD_API is defined as __declspec(dllimport). This results in MSVC returning error C2491 during compilation. Added a preprocessor define UHD_STATIC_LIB in cmake and made the config headers set UHD_API to empty string when UHD_STATIC_LIB is defined.
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index cbc022533..4461612de 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -198,6 +198,7 @@ ENDIF(NOT UHDHOST_PKG)
IF(ENABLE_STATIC_LIBS)
ADD_LIBRARY(uhd_static STATIC ${libuhd_sources})
SET_TARGET_PROPERTIES(uhd_static PROPERTIES OUTPUT_NAME uhd)
+ SET_TARGET_PROPERTIES(uhd_static PROPERTIES COMPILE_DEFINITIONS UHD_STATIC_LIB)
INSTALL(TARGETS uhd_static
ARCHIVE DESTINATION lib${LIB_SUFFIX} # .lib or .a file
)