aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-30 14:12:11 +0000
committerJosh Blum <josh@joshknows.com>2010-03-30 14:12:11 +0000
commitc81a975766a8831cab1e3123af94b4fe4a09d9bc (patch)
tree7b3185f8829495a023344b162e4f77122705847d /host/lib/CMakeLists.txt
parentf94fa1e464c9e2a87274c991dc6461f7f4c956d8 (diff)
downloaduhd-c81a975766a8831cab1e3123af94b4fe4a09d9bc.tar.gz
uhd-c81a975766a8831cab1e3123af94b4fe4a09d9bc.tar.bz2
uhd-c81a975766a8831cab1e3123af94b4fe4a09d9bc.zip
compiling with master merge, renamed usrp1e to usrp_e
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt20
1 files changed, 11 insertions, 9 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 323b69b14..db5e9d273 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -51,6 +51,8 @@ LIST(APPEND libuhd_sources
########################################################################
# Conditionally add the usrp1e sources
########################################################################
+MESSAGE(STATUS "Configuring usrp-e support...")
+
INCLUDE(CheckIncludeFiles)
SET(usrp1e_required_headers
linux/ioctl.h
@@ -63,19 +65,19 @@ CHECK_INCLUDE_FILES(
)
IF(HAS_USRP1E_REQUIRED_HEADERS)
- MESSAGE(STATUS "Building usrp1e support...")
+ MESSAGE(STATUS " Building usrp1e support.")
LIST(APPEND libuhd_sources
- usrp/usrp1e/dboard_impl.cpp
- usrp/usrp1e/dboard_interface.cpp
- usrp/usrp1e/dsp_impl.cpp
- usrp/usrp1e/fpga-downloader.cc
- usrp/usrp1e/mboard_impl.cpp
- usrp/usrp1e/usrp1e_impl.cpp
+ usrp/usrp_e/dboard_impl.cpp
+ usrp/usrp_e/dboard_interface.cpp
+ usrp/usrp_e/dsp_impl.cpp
+ usrp/usrp_e/fpga-downloader.cc
+ usrp/usrp_e/mboard_impl.cpp
+ usrp/usrp_e/usrp_e_impl.cpp
)
ELSE(HAS_USRP1E_REQUIRED_HEADERS)
- MESSAGE(STATUS "Skipping usrp1e support...")
+ MESSAGE(STATUS " Skipping usrp1e support.")
LIST(APPEND libuhd_sources
- usrp/usrp1e/usrp1e_none.cpp
+ usrp/usrp_e/usrp_e_none.cpp
)
ENDIF(HAS_USRP1E_REQUIRED_HEADERS)