aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-02 22:07:17 -0800
committerJosh Blum <josh@joshknows.com>2010-03-02 22:07:17 -0800
commit4efafcc2e20b9a980800a979edf5ea7a493b6462 (patch)
tree49fbf3c6e5b25f31a0de30ecf11ceb19872e590f /host/lib/CMakeLists.txt
parent13bd67b4949a91df5e6696e708c935266b14c502 (diff)
downloaduhd-4efafcc2e20b9a980800a979edf5ea7a493b6462.tar.gz
uhd-4efafcc2e20b9a980800a979edf5ea7a493b6462.tar.bz2
uhd-4efafcc2e20b9a980800a979edf5ea7a493b6462.zip
Expanded the UDP api:
We can make simple udp transports for discovery and control. We can support a udp zero copy transport (currently just asio). Reworked the io_impl for usrp2 to work with the zero copy api. So far, all of this untested other than compiling. A cut-down vrt library is in the works to simplify the io impl.
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 97f1ac52e..a52cd74a9 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -23,7 +23,7 @@ SET(libuhd_sources
device_addr.cpp
gain_handler.cpp
wax.cpp
- transport/udp.cpp
+ transport/udp_simple.cpp
usrp/dboard/basic.cpp
usrp/dboard_base.cpp
usrp/dboard_id.cpp
@@ -38,6 +38,13 @@ SET(libuhd_sources
)
########################################################################
+# Conditionally add the udp sources
+########################################################################
+LIST(APPEND libuhd_sources
+ transport/udp_zero_copy_none.cpp
+)
+
+########################################################################
# Conditionally add the usrp1e sources
########################################################################
LIST(APPEND libuhd_sources