aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-15 17:00:04 +0000
committerJosh Blum <josh@joshknows.com>2010-03-15 17:00:04 +0000
commit1bfb556262d12740c71e68a2a071e6e67ed2b3e7 (patch)
treea081bfd3a61ccb42372a627be7b57ce19a3baa0d /host/lib/CMakeLists.txt
parent1b965831ae7588c7879d84de4e5fbd78ca614761 (diff)
parentfc40ff2f1327d01c72c4d7dbc07a14e473251981 (diff)
downloaduhd-1bfb556262d12740c71e68a2a071e6e67ed2b3e7.tar.gz
uhd-1bfb556262d12740c71e68a2a071e6e67ed2b3e7.tar.bz2
uhd-1bfb556262d12740c71e68a2a071e6e67ed2b3e7.zip
Merge branch 'master' of git@ettus.sourcerepo.com:ettus/uhd into u1e_uhd
Conflicts: host/apps/CMakeLists.txt host/lib/usrp/usrp2/usrp2_impl.cpp
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 33314e729..ca00c3597 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -22,12 +22,14 @@ SET(libuhd_sources
device.cpp
device_addr.cpp
gain_handler.cpp
- uhd.cpp
+ metadata.cpp
+ simple_device.cpp
+ time_spec.cpp
wax.cpp
- transport/udp.cpp
+ transport/udp_simple.cpp
+ transport/vrt.cpp
usrp/dboard/basic.cpp
usrp/dboard_base.cpp
- usrp/dboard_id.cpp
usrp/dboard_interface.cpp
usrp/dboard_manager.cpp
usrp/usrp2/dboard_impl.cpp
@@ -39,6 +41,13 @@ SET(libuhd_sources
)
########################################################################
+# Conditionally add the udp sources
+########################################################################
+LIST(APPEND libuhd_sources
+ transport/udp_zero_copy_none.cpp
+)
+
+########################################################################
# Conditionally add the usrp1e sources
########################################################################
INCLUDE(CheckIncludeFiles)