aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-18 19:38:06 +0000
committerJosh Blum <josh@joshknows.com>2010-03-18 19:38:06 +0000
commit10ee8022dd22f13f942d8bfeeca3b380224fff52 (patch)
treef67582a9ecd381fc8a27d246e752e26eb8b9cb9c /host/lib/CMakeLists.txt
parentd105f614477c7f2a4f24a4efc802de7eb750bd7a (diff)
downloaduhd-10ee8022dd22f13f942d8bfeeca3b380224fff52.tar.gz
uhd-10ee8022dd22f13f942d8bfeeca3b380224fff52.tar.bz2
uhd-10ee8022dd22f13f942d8bfeeca3b380224fff52.zip
added usrp1e implementation skeleton, began filling it in...
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 7d7fcbea9..e547fef85 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -63,7 +63,11 @@ CHECK_INCLUDE_FILES(
IF(HAS_USRP1E_REQUIRED_HEADERS)
MESSAGE(STATUS "Building usrp1e support...")
LIST(APPEND libuhd_sources
+ usrp/usrp1e/dboard_impl.cpp
+ usrp/usrp1e/dboard_interface.cpp
+ usrp/usrp1e/dsp_impl.cpp
usrp/usrp1e/fpga-downloader.cc
+ usrp/usrp1e/mboard_impl.cpp
usrp/usrp1e/usrp1e_impl.cpp
)
ELSE(HAS_USRP1E_REQUIRED_HEADERS)