aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-05-06 22:00:21 +0000
committerJosh Blum <josh@joshknows.com>2010-05-06 22:00:21 +0000
commit06bcfc6b872d8efcb94b312b963f18678a862b93 (patch)
treed495ab8d7291dac612910b7ee880d4ec96844999 /host/lib/CMakeLists.txt
parent7790eeb944f7eace8fae16b80820f71dd5bc3a87 (diff)
downloaduhd-06bcfc6b872d8efcb94b312b963f18678a862b93.tar.gz
uhd-06bcfc6b872d8efcb94b312b963f18678a862b93.tar.bz2
uhd-06bcfc6b872d8efcb94b312b963f18678a862b93.zip
moved usrp_e specific build stuff into its own cmake file
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt37
1 files changed, 1 insertions, 36 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index f64f1dbac..6cf896db8 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -72,42 +72,7 @@ INCLUDE(${CMAKE_CURRENT_SOURCE_DIR}/transport/CMakeLists.txt)
INCLUDE(${CMAKE_CURRENT_SOURCE_DIR}/usrp/CMakeLists.txt)
INCLUDE(${CMAKE_CURRENT_SOURCE_DIR}/usrp/dboard/CMakeLists.txt)
INCLUDE(${CMAKE_CURRENT_SOURCE_DIR}/usrp/usrp2/CMakeLists.txt)
-
-########################################################################
-# Conditionally add the usrp1e sources
-########################################################################
-MESSAGE(STATUS "Configuring usrp-e support...")
-
-INCLUDE(CheckIncludeFiles)
-SET(usrp_e_required_headers
- linux/ioctl.h
- linux/spi/spidev.h
- linux/usrp_e.h
-)
-CHECK_INCLUDE_FILES(
- "${usrp_e_required_headers}"
- HAVE_USRP_E_REQUIRED_HEADERS
-)
-
-IF(HAVE_USRP_E_REQUIRED_HEADERS)
- MESSAGE(STATUS " Building usrp-e support.")
- LIST(APPEND libuhd_sources
- usrp/usrp_e/clock_ctrl.cpp
- usrp/usrp_e/codec_ctrl.cpp
- usrp/usrp_e/dboard_impl.cpp
- usrp/usrp_e/dboard_iface.cpp
- usrp/usrp_e/dsp_impl.cpp
- usrp/usrp_e/fpga-downloader.cc
- usrp/usrp_e/mboard_impl.cpp
- usrp/usrp_e/usrp_e_impl.cpp
- usrp/usrp_e/usrp_e_iface.cpp
- )
-ELSE(HAVE_USRP_E_REQUIRED_HEADERS)
- MESSAGE(STATUS " Skipping usrp-e support.")
- LIST(APPEND libuhd_sources
- usrp/usrp_e/usrp_e_none.cpp
- )
-ENDIF(HAVE_USRP_E_REQUIRED_HEADERS)
+INCLUDE(${CMAKE_CURRENT_SOURCE_DIR}/usrp/usrp_e/CMakeLists.txt)
########################################################################
# Setup defines for module loading