aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-09-09 12:24:20 -0700
committerJosh Blum <josh@joshknows.com>2010-09-09 12:24:20 -0700
commitb7e3450a9b02e3236f94d06e5102a47567733963 (patch)
tree9140a55daed9332073fb8ec77e1ce2593963186a /host/examples/CMakeLists.txt
parent6d315076ba2ef5aa7612ebe3cf39f72bc2bb76e5 (diff)
downloaduhd-b7e3450a9b02e3236f94d06e5102a47567733963.tar.gz
uhd-b7e3450a9b02e3236f94d06e5102a47567733963.tar.bz2
uhd-b7e3450a9b02e3236f94d06e5102a47567733963.zip
usrp: test for async messages, also renamed pps test
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
index 5b241e284..d19838335 100644
--- a/host/examples/CMakeLists.txt
+++ b/host/examples/CMakeLists.txt
@@ -15,27 +15,31 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-
+########################################################################
ADD_EXECUTABLE(benchmark_rx_rate benchmark_rx_rate.cpp)
TARGET_LINK_LIBRARIES(benchmark_rx_rate uhd)
ADD_EXECUTABLE(rx_timed_samples rx_timed_samples.cpp)
TARGET_LINK_LIBRARIES(rx_timed_samples uhd)
+ADD_EXECUTABLE(test_async_messages test_async_messages.cpp)
+TARGET_LINK_LIBRARIES(test_async_messages uhd)
+
+ADD_EXECUTABLE(test_pps_input test_pps_input.cpp)
+TARGET_LINK_LIBRARIES(test_pps_input uhd)
+
ADD_EXECUTABLE(tx_timed_samples tx_timed_samples.cpp)
TARGET_LINK_LIBRARIES(tx_timed_samples uhd)
ADD_EXECUTABLE(tx_waveforms tx_waveforms.cpp)
TARGET_LINK_LIBRARIES(tx_waveforms uhd)
-ADD_EXECUTABLE(pps_test pps_test.cpp)
-TARGET_LINK_LIBRARIES(pps_test uhd)
-
INSTALL(TARGETS
benchmark_rx_rate
rx_timed_samples
+ test_async_messages
+ test_pps_input
tx_timed_samples
tx_waveforms
- pps_test
RUNTIME DESTINATION ${PKG_DATA_DIR}/examples
)