aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-06-24 18:55:08 -0700
committerJosh Blum <josh@joshknows.com>2010-06-24 18:55:08 -0700
commitfadd3a44a84e061412accd35c1c97db820190df8 (patch)
tree3bae768f567858b6dc61f24cd643819c9c9c2380 /host/examples/CMakeLists.txt
parente74356ec5956d10d399969851fefd4a1f308ad7c (diff)
downloaduhd-fadd3a44a84e061412accd35c1c97db820190df8.tar.gz
uhd-fadd3a44a84e061412accd35c1c97db820190df8.tar.bz2
uhd-fadd3a44a84e061412accd35c1c97db820190df8.zip
uhd: created benchmark rx example app
Made mods to time spec to support math operators.
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
index a537c0901..5071b114f 100644
--- a/host/examples/CMakeLists.txt
+++ b/host/examples/CMakeLists.txt
@@ -15,10 +15,18 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
+ADD_EXECUTABLE(benchmark_rx_rate benchmark_rx_rate.cpp)
+TARGET_LINK_LIBRARIES(benchmark_rx_rate uhd)
+
ADD_EXECUTABLE(rx_timed_samples rx_timed_samples.cpp)
TARGET_LINK_LIBRARIES(rx_timed_samples uhd)
-INSTALL(TARGETS rx_timed_samples RUNTIME DESTINATION ${PKG_DATA_DIR}/examples)
ADD_EXECUTABLE(tx_timed_samples tx_timed_samples.cpp)
TARGET_LINK_LIBRARIES(tx_timed_samples uhd)
-INSTALL(TARGETS tx_timed_samples RUNTIME DESTINATION ${PKG_DATA_DIR}/examples)
+
+INSTALL(TARGETS
+ benchmark_rx_rate
+ rx_timed_samples
+ tx_timed_samples
+ RUNTIME DESTINATION ${PKG_DATA_DIR}/examples
+)