aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-09-09 16:21:57 -0700
committerJosh Blum <josh@joshknows.com>2010-09-09 16:21:57 -0700
commit901fd9fc2630b7a142cd6633965dbd457fbb88bd (patch)
tree21f7171ede4de542a85eb4622c88a92e2b4da0a0 /host/examples/CMakeLists.txt
parent4a757e64cbb513e6461e547f4d095b0539ae0b09 (diff)
parent72646d1960b0c979afec225e741d7d89a827c7d0 (diff)
downloaduhd-901fd9fc2630b7a142cd6633965dbd457fbb88bd.tar.gz
uhd-901fd9fc2630b7a142cd6633965dbd457fbb88bd.tar.bz2
uhd-901fd9fc2630b7a142cd6633965dbd457fbb88bd.zip
Merge branch 'master' into usrp_e
Conflicts: host/examples/CMakeLists.txt
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
index 7da31a16b..fb7777d42 100644
--- a/host/examples/CMakeLists.txt
+++ b/host/examples/CMakeLists.txt
@@ -15,7 +15,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-
+########################################################################
ADD_EXECUTABLE(benchmark_rx_rate benchmark_rx_rate.cpp)
TARGET_LINK_LIBRARIES(benchmark_rx_rate uhd)
@@ -25,6 +25,12 @@ TARGET_LINK_LIBRARIES(rx_timed_samples uhd)
ADD_EXECUTABLE(rx_to_file rx_to_file.cpp)
TARGET_LINK_LIBRARIES(rx_to_file uhd)
+ADD_EXECUTABLE(test_async_messages test_async_messages.cpp)
+TARGET_LINK_LIBRARIES(test_async_messages uhd)
+
+ADD_EXECUTABLE(test_pps_input test_pps_input.cpp)
+TARGET_LINK_LIBRARIES(test_pps_input uhd)
+
ADD_EXECUTABLE(tx_timed_samples tx_timed_samples.cpp)
TARGET_LINK_LIBRARIES(tx_timed_samples uhd)
@@ -34,16 +40,14 @@ TARGET_LINK_LIBRARIES(tx_from_file uhd)
ADD_EXECUTABLE(tx_waveforms tx_waveforms.cpp)
TARGET_LINK_LIBRARIES(tx_waveforms uhd)
-ADD_EXECUTABLE(pps_test pps_test.cpp)
-TARGET_LINK_LIBRARIES(pps_test uhd)
-
INSTALL(TARGETS
benchmark_rx_rate
rx_timed_samples
+ test_async_messages
+ test_pps_input
tx_timed_samples
tx_from_file
rx_to_file
tx_waveforms
- pps_test
RUNTIME DESTINATION ${PKG_DATA_DIR}/examples
)