aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2013-05-10 14:59:04 -0700
committerNicholas Corgan <nick.corgan@ettus.com>2013-05-10 15:04:00 -0700
commit4b72513a8930ec4147dab76c079afa1186e335cd (patch)
treec83c3323385266fe99f5132dbfc74fb636b9e6ba /host/examples/CMakeLists.txt
parentd63ce4fc3aabc208d97b5ff2a14bf2ba351103e7 (diff)
downloaduhd-4b72513a8930ec4147dab76c079afa1186e335cd.tar.gz
uhd-4b72513a8930ec4147dab76c079afa1186e335cd.tar.bz2
uhd-4b72513a8930ec4147dab76c079afa1186e335cd.zip
Added CMake variables to customize builds to match Debian package configurations
* -DLIBUHD_PKG=ON installs with libuhd003 configuration * -DLIBUHDDEV_PKG=ON installs with libuhd-dev configuration * -DUHDHOST_PKG=ON installs with uhd-host configuration
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
index 3ba483134..bdefeba0a 100644
--- a/host/examples/CMakeLists.txt
+++ b/host/examples/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright 2010-2012 Ettus Research LLC
+# Copyright 2010-2013 Ettus Research LLC
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -43,7 +43,7 @@ FOREACH(example_source ${example_sources})
GET_FILENAME_COMPONENT(example_name ${example_source} NAME_WE)
ADD_EXECUTABLE(${example_name} ${example_source})
TARGET_LINK_LIBRARIES(${example_name} uhd)
- INSTALL(TARGETS ${example_name} RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+ UHD_INSTALL(TARGETS ${example_name} RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
ENDFOREACH(example_source)
########################################################################
@@ -55,5 +55,5 @@ IF(CURSES_FOUND)
INCLUDE_DIRECTORIES(${CURSES_INCLUDE_DIR})
ADD_EXECUTABLE(rx_ascii_art_dft rx_ascii_art_dft.cpp)
TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES})
- INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+ UHD_INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
ENDIF(CURSES_FOUND)