aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-10-25 10:23:59 -0700
committerJosh Blum <josh@joshknows.com>2010-10-25 10:23:59 -0700
commit3c6ede3c4104d483f39b3c4d062e9e837a9e2e08 (patch)
tree93a0a50a22dfe08a6f27d0c98b0cca82dfe0f8c9 /host/examples/CMakeLists.txt
parent3974e544393bd5a720838cbf4790c532bca2aae4 (diff)
downloaduhd-3c6ede3c4104d483f39b3c4d062e9e837a9e2e08.tar.gz
uhd-3c6ede3c4104d483f39b3c4d062e9e837a9e2e08.tar.bz2
uhd-3c6ede3c4104d483f39b3c4d062e9e837a9e2e08.zip
created ascii art dft plotter in uhd
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
index d19838335..a8873f8d3 100644
--- a/host/examples/CMakeLists.txt
+++ b/host/examples/CMakeLists.txt
@@ -43,3 +43,15 @@ INSTALL(TARGETS
tx_waveforms
RUNTIME DESTINATION ${PKG_DATA_DIR}/examples
)
+
+########################################################################
+# ASCII Art DFT - requires curses, so this part is optional
+########################################################################
+INCLUDE(FindCurses)
+
+IF(CURSES_FOUND)
+ INCLUDE_DIRECTORIES(${CURSES_INCLUDE_DIR})
+ ADD_EXECUTABLE(rx_ascii_art_dft rx_ascii_art_dft.cpp)
+ TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES})
+ INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_DATA_DIR}/examples)
+ENDIF(CURSES_FOUND)