aboutsummaryrefslogtreecommitdiffstats
path: root/host/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2014-03-23 15:11:26 +0100
committerMartin Braun <martin.braun@ettus.com>2014-04-09 17:25:09 +0200
commita74919c2a89a6b1ae40b526c4ceadf1108bfd186 (patch)
tree79cb43c5d7ed3caa1fe8b695001267f0cc8286bf /host/docs/CMakeLists.txt
parent47bf17b50a305228cfd07ff6fbaff3ac4a30e811 (diff)
downloaduhd-a74919c2a89a6b1ae40b526c4ceadf1108bfd186.tar.gz
uhd-a74919c2a89a6b1ae40b526c4ceadf1108bfd186.tar.bz2
uhd-a74919c2a89a6b1ae40b526c4ceadf1108bfd186.zip
docs: Moved manual to Doxygen
Diffstat (limited to 'host/docs/CMakeLists.txt')
-rw-r--r--host/docs/CMakeLists.txt79
1 files changed, 8 insertions, 71 deletions
diff --git a/host/docs/CMakeLists.txt b/host/docs/CMakeLists.txt
index 1ee0f1ade..015fa9dbb 100644
--- a/host/docs/CMakeLists.txt
+++ b/host/docs/CMakeLists.txt
@@ -18,89 +18,26 @@
########################################################################
# List of manual sources
########################################################################
-SET(manual_sources
- index.rst
- identification.rst
- build.rst
- calibration.rst
- coding.rst
- dboards.rst
- gpio_api.rst
- gpsdo.rst
- gpsdo_b2x0.rst
- gpsdo_x3x0.rst
- general.rst
- images.rst
- stream.rst
- sync.rst
- transport.rst
- usrp1.rst
- usrp2.rst
- usrp_b100.rst
- usrp_b200.rst
- usrp_e1x0.rst
- usrp_x3x0.rst
- usrp_x3x0_config.rst
-)
########################################################################
# Setup Manual
########################################################################
MESSAGE(STATUS "")
-FIND_PACKAGE(Docutils)
-
-LIBUHD_REGISTER_COMPONENT("Manual" ENABLE_MANUAL ON "DOCUTILS_FOUND" OFF)
-
-IF(UHDHOST_PKG)
- SET(PKG_DOC_DIR share/doc/uhd-host)
-ENDIF(UHDHOST_PKG)
+FIND_PACKAGE(Doxygen)
+LIBUHD_REGISTER_COMPONENT("Manual" ENABLE_MANUAL ON "DOXYGEN_FOUND" OFF)
+# TODO conditionally add the manual to Doxygen, now it just adds dependencies
IF(ENABLE_MANUAL)
- #setup rst2html options
- SET(stylesheet ${CMAKE_CURRENT_SOURCE_DIR}/style.css)
- SET(rst2html_options
- --stylesheet=${stylesheet}
- --no-toc-backlinks --date --time
- )
-
- #create generation rule for each source
- FOREACH(rstfile ${manual_sources})
- #set input and output file names
- SET(rstfile ${CMAKE_CURRENT_SOURCE_DIR}/${rstfile})
- GET_FILENAME_COMPONENT(rstfile_we ${rstfile} NAME_WE)
- SET(htmlfile ${CMAKE_CURRENT_BINARY_DIR}/${rstfile_we}.html)
-
- #make the html file depend on the rst file
- ADD_CUSTOM_COMMAND(
- OUTPUT ${htmlfile} DEPENDS ${rstfile} ${stylesheet}
- COMMAND ${RST2HTML_EXECUTABLE} ${rstfile} ${htmlfile} ${rst2html_options}
- COMMENT "Generating ${htmlfile}"
- )
-
- #make the manual target depend on the html file
- LIST(APPEND manual_html_files ${htmlfile})
- UHD_INSTALL(FILES ${htmlfile} DESTINATION ${PKG_DOC_DIR}/manual/html COMPONENT manual)
- ENDFOREACH(rstfile ${manual_sources})
-
- #make the html manual a build-time dependency
- ADD_CUSTOM_TARGET(manual_html ALL DEPENDS ${manual_html_files})
- UHD_INSTALL(FILES ${manual_sources} DESTINATION ${PKG_DOC_DIR}/manual/rst COMPONENT manual)
-
- #resources for html manual
- ADD_CUSTOM_COMMAND(
- TARGET manual_html POST_BUILD
- COMMAND ${CMAKE_COMMAND} -E copy_directory ${CMAKE_CURRENT_SOURCE_DIR}/res ${CMAKE_CURRENT_BINARY_DIR}/res
- )
- UHD_INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/res DESTINATION ${PKG_DOC_DIR}/manual/html COMPONENT manual)
-
+ FILE(GLOB manual_sources "*.dox")
+ELSE(ENABLE_MANUAL)
+ SET(manual_source "")
ENDIF(ENABLE_MANUAL)
+
########################################################################
# Setup Doxygen
########################################################################
MESSAGE(STATUS "")
-FIND_PACKAGE(Doxygen)
-
LIBUHD_REGISTER_COMPONENT("Doxygen" ENABLE_DOXYGEN ON "DOXYGEN_FOUND" OFF)
IF(LIBUHDDEV_PKG)
@@ -118,7 +55,7 @@ IF(ENABLE_DOXYGEN)
#make doxygen directory depend on the header files
FILE(GLOB_RECURSE header_files ${CMAKE_SOURCE_DIR}/include/*.hpp)
ADD_CUSTOM_COMMAND(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR_DOXYGEN} DEPENDS ${header_files}
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR_DOXYGEN} DEPENDS ${header_files} ${manual_source}
COMMAND ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
COMMENT "Generating documentation with doxygen"
)