aboutsummaryrefslogtreecommitdiffstats
path: root/host/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2016-05-06 11:02:54 -0700
committerMartin Braun <martin.braun@ettus.com>2016-05-06 11:02:54 -0700
commit30c3a9f0d5ef628855b9cbd0c68b6a92f238e03b (patch)
tree3284367df76378c768f296019ebce3e724f86b4b /host/docs/CMakeLists.txt
parent8e1f759a4ce3a5a00c5087daa5fc6dd25ceed74c (diff)
parent8426569f5c6ee954c5f0345351bd8239725a8fee (diff)
downloaduhd-30c3a9f0d5ef628855b9cbd0c68b6a92f238e03b.tar.gz
uhd-30c3a9f0d5ef628855b9cbd0c68b6a92f238e03b.tar.bz2
uhd-30c3a9f0d5ef628855b9cbd0c68b6a92f238e03b.zip
Merge branch 'maint'
Conflicts: host/CMakeLists.txt host/lib/usrp/b200/b200_impl.cpp
Diffstat (limited to 'host/docs/CMakeLists.txt')
-rw-r--r--host/docs/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/host/docs/CMakeLists.txt b/host/docs/CMakeLists.txt
index 7f510f58c..a702f76c6 100644
--- a/host/docs/CMakeLists.txt
+++ b/host/docs/CMakeLists.txt
@@ -66,6 +66,7 @@ ENDIF(ENABLE_MANUAL)
LIBUHD_REGISTER_COMPONENT("API/Doxygen" ENABLE_DOXYGEN ON "DOXYGEN_FOUND" OFF OFF)
OPTION(ENABLE_DOXYGEN_FULL "Use Doxygen to document the entire source tree (not just API)" OFF)
OPTION(ENABLE_DOXYGEN_DOT "Let Doxygen use dot (requires graphviz)" OFF)
+OPTION(ENABLE_DOXYGEN_SHORTNAMES "Let Doxygen use shorter filenames (helps on Windows)" OFF)
IF(LIBUHDDEV_PKG)
SET(PKG_DOC_DIR share/doc/libuhd-dev)
@@ -98,6 +99,11 @@ IF(ENABLE_MANUAL_OR_DOXYGEN)
ELSE(ENABLE_DOXYGEN_DOT)
SET(DOXYGEN_HAVE_DOT "NO")
ENDIF(ENABLE_DOXYGEN_DOT)
+ IF(ENABLE_DOXYGEN_SHORTNAMES)
+ SET(DOXYGEN_SHORT_NAMES "YES")
+ ELSE(ENABLE_DOXYGEN_SHORTNAMES)
+ SET(DOXYGEN_SHORT_NAMES "NO")
+ ENDIF(ENABLE_DOXYGEN_SHORTNAMES)
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in