aboutsummaryrefslogtreecommitdiffstats
path: root/host/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2016-08-12 17:38:01 -0700
committerMartin Braun <martin.braun@ettus.com>2016-08-12 17:38:01 -0700
commit13acda91b51d7e053e38a1f5f7d7864d85622e83 (patch)
treeb08730e1b2dbe129b6d8e9839ccf21f3acca538f /host/docs/CMakeLists.txt
parent108c5385cabf17c64fe8b7b7a36d9b8ea4d1e73a (diff)
downloaduhd-13acda91b51d7e053e38a1f5f7d7864d85622e83.tar.gz
uhd-13acda91b51d7e053e38a1f5f7d7864d85622e83.tar.bz2
uhd-13acda91b51d7e053e38a1f5f7d7864d85622e83.zip
doxygen: Exclude RFNoC includes if ENABLE_RFNOC is off
Diffstat (limited to 'host/docs/CMakeLists.txt')
-rw-r--r--host/docs/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/host/docs/CMakeLists.txt b/host/docs/CMakeLists.txt
index a702f76c6..e60f6a35d 100644
--- a/host/docs/CMakeLists.txt
+++ b/host/docs/CMakeLists.txt
@@ -45,6 +45,10 @@ IF(ENABLE_MANUAL)
SET(DOXYGEN_DEP_COMPONENT "manual")
SET(DOXYGEN_FPGA_MANUAL_REFERENCE "<a href=\"http://files.ettus.com/manual/md_fpga.html\">Part III: FPGA Manual</a>")
SET(DOXYGEN_STRIP_EXTRA "")
+ SET(DOXYGEN_EXCLUDE_DIRS "")
+ IF(NOT ENABLE_RFNOC)
+ SET(DOXYGEN_EXCLUDE_DIRS "${DOXYGEN_EXCLUDE_DIRS} ${CMAKE_SOURCE_DIR}/include/uhd/rfnoc")
+ ENDIF(NOT ENABLE_RFNOC)
# Now, check if we have the FPGA sources as well.
# If so, pull them in:
IF(HAS_FPGA_SUBMODULE)