summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2014-08-14 06:45:53 -0700
committerNicholas Corgan <nick.corgan@ettus.com>2014-08-14 06:45:53 -0700
commite3826b1a671f4fe9e197b72a9c8dc0aa6976ea0c (patch)
tree47d899052407ea405b397786966bf69b6fd78cef /host/CMakeLists.txt
parent781d7a24aba25ab045d2f4456071ce9aad3b389c (diff)
downloaduhd-e3826b1a671f4fe9e197b72a9c8dc0aa6976ea0c.tar.gz
uhd-e3826b1a671f4fe9e197b72a9c8dc0aa6976ea0c.tar.bz2
uhd-e3826b1a671f4fe9e197b72a9c8dc0aa6976ea0c.zip
Restoring compatibility with CMake 2.6
* The UNSET command didn't exist back then, but using SET with no value does the same thing * CMake 2.6 doesn't like nested parantheses in IF statements, so tweak IF/ELSE statements
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 2c574c54f..ba16ce894 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -149,7 +149,7 @@ IF(MSVC)
IF(BOOST_ALL_DYN_LINK)
ADD_DEFINITIONS(-DBOOST_ALL_DYN_LINK) #setup boost auto-linking in msvc
ELSE(BOOST_ALL_DYN_LINK)
- UNSET(BOOST_REQUIRED_COMPONENTS) #empty components list for static link
+ SET(BOOST_REQUIRED_COMPONENTS) #empty components list for static link
ENDIF(BOOST_ALL_DYN_LINK)
ENDIF(MSVC)
@@ -262,8 +262,8 @@ STRING(REPLACE ";" " " UHD_PC_LIBS "${UHD_PC_LIBS}")
#unset these vars to avoid hard-coded paths to cross environment
IF(CMAKE_CROSSCOMPILING)
- UNSET(UHD_PC_CFLAGS)
- UNSET(UHD_PC_LIBS)
+ SET(UHD_PC_CFLAGS)
+ SET(UHD_PC_LIBS)
ENDIF(CMAKE_CROSSCOMPILING)
IF(NOT LIBUHD_PKG AND NOT UHDHOST_PKG)