summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2013-02-01 12:38:47 -0800
committerNicholas Corgan <nick.corgan@ettus.com>2013-02-01 12:38:47 -0800
commit6e8f39de53f135b246bd8c60b039aef1e917e902 (patch)
treeed6bc26593c25b615496631dddd351dc2565dffd /host/CMakeLists.txt
parente134b8639025bd8b42c9640f3f409f61e2cc8b8c (diff)
parenta728458c32aa58da2dbf8ff401350b5322309dd4 (diff)
downloaduhd-6e8f39de53f135b246bd8c60b039aef1e917e902.tar.gz
uhd-6e8f39de53f135b246bd8c60b039aef1e917e902.tar.bz2
uhd-6e8f39de53f135b246bd8c60b039aef1e917e902.zip
Merge branch 'maint'
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 5daaf44e0..78b8b4255 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -123,9 +123,9 @@ SET(BOOST_REQUIRED_COMPONENTS
unit_test_framework
)
-IF(UNIX AND EXISTS "/usr/lib64")
+IF(UNIX AND NOT BOOST_ROOT AND EXISTS "/usr/lib64")
LIST(APPEND BOOST_LIBRARYDIR "/usr/lib64") #fedora 64-bit fix
-ENDIF(UNIX AND EXISTS "/usr/lib64")
+ENDIF(UNIX AND NOT BOOST_ROOT AND EXISTS "/usr/lib64")
IF(MSVC)
SET(BOOST_ALL_DYN_LINK "${BOOST_ALL_DYN_LINK}" CACHE BOOL "boost enable dynamic linking")