summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-04-05 16:32:48 -0700
committerJosh Blum <josh@joshknows.com>2011-04-05 16:32:48 -0700
commitdbfbc497a8e0a144e0db2b8daa0f4baba5284775 (patch)
tree91e52b36dc45eea92974449105c79f1048edaf10 /host/CMakeLists.txt
parent6a2fbe07e7674794a883a7062ce2225781cf5193 (diff)
downloaduhd-dbfbc497a8e0a144e0db2b8daa0f4baba5284775.tar.gz
uhd-dbfbc497a8e0a144e0db2b8daa0f4baba5284775.tar.bz2
uhd-dbfbc497a8e0a144e0db2b8daa0f4baba5284775.zip
uhd: tweaks for cygwin/mingw, always link winsock2, findusb1, __USE_W32_SOCKETS
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 7df04995c..552fe492c 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -90,6 +90,10 @@ IF(MSVC)
)
ENDIF(MSVC)
+IF(CYGWIN)
+ ADD_DEFINITIONS(-D__USE_W32_SOCKETS) #boost asio says we need this
+ENDIF(CYGWIN)
+
IF(WIN32)
ADD_DEFINITIONS(-D_WIN32_WINNT=0x0501) #minimum version required is windows xp
ADD_DEFINITIONS(-DNOMINMAX) #disables stupidity and enables std::min and std::max