summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2013-10-23 10:09:04 -0700
committerNicholas Corgan <nick.corgan@ettus.com>2013-10-23 10:44:43 -0700
commitb488026ea1996a15946ed492bf3511a401d0f727 (patch)
tree7fc09ed00f5c08c585a79b7629ad43ab22e0ba37 /host/CMakeLists.txt
parenta219f16c3d5395ca0da7df65d8d82a3320705379 (diff)
downloaduhd-b488026ea1996a15946ed492bf3511a401d0f727.tar.gz
uhd-b488026ea1996a15946ed492bf3511a401d0f727.tar.bz2
uhd-b488026ea1996a15946ed492bf3511a401d0f727.zip
cmake: fixed UHD_IMAGES_DIR behavior to include directories inside specified images directory
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index ebd6c1e00..602e9aa67 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -284,7 +284,7 @@ ENDIF(NOT LIBUHD_PKG AND NOT UHDHOST_PKG)
# Handle pre-built images
########################################################################
IF(DEFINED UHD_IMAGES_DIR AND EXISTS "${UHD_IMAGES_DIR}")
- FILE(GLOB _image_files "${UHD_IMAGES_DIR}/*.*")
+ FILE(GLOB_RECURSE _image_files "${UHD_IMAGES_DIR}/*")
MESSAGE(STATUS "Using images:")
FOREACH(_img ${_image_files})
MESSAGE(STATUS " ${_img}")