summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-04-01 10:28:58 -0700
committerJosh Blum <josh@joshknows.com>2011-04-01 10:28:58 -0700
commit592af4a86be7309a858e04d1e930d8ac6932db18 (patch)
tree43e9e48f9a494bcabc6287d298d88945cf7e3230 /host/CMakeLists.txt
parent1721352e905e10dbff48d44b66b1684020a103d7 (diff)
downloaduhd-592af4a86be7309a858e04d1e930d8ac6932db18.tar.gz
uhd-592af4a86be7309a858e04d1e930d8ac6932db18.tar.bz2
uhd-592af4a86be7309a858e04d1e930d8ac6932db18.zip
uhd: disable visibility=hidden on non-dll platforms (cygwin)
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 244793b9e..606742865 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -72,8 +72,10 @@ IF(CMAKE_COMPILER_IS_GNUCXX)
ADD_DEFINITIONS(-Wextra)
#ADD_DEFINITIONS(-pedantic)
#ADD_DEFINITIONS(-ansi)
- #only export symbols that are declared to be part of the uhd api:
- UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_HIDDEN)
+ IF(NOT WIN32)
+ #only export symbols that are declared to be part of the uhd api (non dll platforms)
+ UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_HIDDEN)
+ ENDIF(NOT WIN32)
ENDIF(CMAKE_COMPILER_IS_GNUCXX)
IF(MSVC)