summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2013-05-10 16:39:52 -0700
committerNicholas Corgan <nick.corgan@ettus.com>2013-05-10 16:56:20 -0700
commit7d0121fc7983322b5e34eec449b74a55e21a1678 (patch)
treeb13625e6431c1b2a2a5c1e71e1f07f6e2fea45fa /host/CMakeLists.txt
parent4b72513a8930ec4147dab76c079afa1186e335cd (diff)
downloaduhd-7d0121fc7983322b5e34eec449b74a55e21a1678.tar.gz
uhd-7d0121fc7983322b5e34eec449b74a55e21a1678.tar.bz2
uhd-7d0121fc7983322b5e34eec449b74a55e21a1678.zip
cmake: GCC strips binaries unless build type is specified
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index c7332e3a2..cdcfc6529 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -84,6 +84,9 @@ SET(CMAKE_BUILD_TYPE "${CMAKE_BUILD_TYPE}" CACHE STRING "")
SET(UHD_RELEASE_MODE "${UHD_RELEASE_MODE}" CACHE STRING "UHD Release Mode")
IF(CMAKE_COMPILER_IS_GNUCXX)
+ IF(NOT CMAKE_BUILD_TYPE STREQUAL "Debug")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -s")
+ ENDIF(NOT CMAKE_BUILD_TYPE STREQUAL "Debug")
ADD_DEFINITIONS(-Wall)
ADD_DEFINITIONS(-Wextra)
ADD_DEFINITIONS(-Wsign-compare)