summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-02-16 17:19:54 -0800
committerJosh Blum <josh@joshknows.com>2011-02-16 17:19:54 -0800
commit2af3e5c49d9729339af06ce90a5810b316dc1513 (patch)
treecd9a4ef9afd2e40eaaf4752f4546499a43cf7555 /host/CMakeLists.txt
parent8878b35d596e2f4db8b3e0189adfcaee81c8300f (diff)
downloaduhd-2af3e5c49d9729339af06ce90a5810b316dc1513.tar.gz
uhd-2af3e5c49d9729339af06ce90a5810b316dc1513.tar.bz2
uhd-2af3e5c49d9729339af06ce90a5810b316dc1513.zip
uhd: tweaks for windows msvc compiler warnings and errors
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index baa5ab662..523944355 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -79,7 +79,12 @@ IF(MSVC)
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/msvc)
ADD_DEFINITIONS(-D_WIN32_WINNT=0x0501) #minimum version required is windows xp
ADD_DEFINITIONS(-DNOMINMAX) #disables stupidity and enables std::min and std::max
- ADD_DEFINITIONS(-D_SCL_SECURE_NO_WARNINGS) #avoid warnings from boost::split
+ ADD_DEFINITIONS( #stop all kinds of compatibility warnings
+ -D_SCL_SECURE_NO_WARNINGS
+ -D_CRT_SECURE_NO_WARNINGS
+ -D_CRT_SECURE_NO_DEPRECATE
+ -D_CRT_NONSTDC_NO_DEPRECATE
+ )
ADD_DEFINITIONS(-DBOOST_ALL_DYN_LINK) #setup boost auto-linking in msvc
ENDIF(MSVC)