summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-01-24 10:29:40 -0800
committerJosh Blum <josh@joshknows.com>2011-01-24 10:30:56 -0800
commitff796f519df11111f028a505125ce95f060c897e (patch)
tree732856853ca5e62e83bc5bacd48a02ed129c46ca /host/CMakeLists.txt
parentcd5631ff194ae8b8ca6308286e44704785ef792a (diff)
downloaduhd-ff796f519df11111f028a505125ce95f060c897e.tar.gz
uhd-ff796f519df11111f028a505125ce95f060c897e.tar.bz2
uhd-ff796f519df11111f028a505125ce95f060c897e.zip
uhd: added docs on usrp2/n, removed empty n2xx doc page, misc
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index d0c576ee5..e64c1031f 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -65,8 +65,6 @@ ENDIF(NOT CMAKE_BUILD_TYPE)
IF(CMAKE_COMPILER_IS_GNUCXX)
ADD_DEFINITIONS(-Wall)
ADD_DEFINITIONS(-Wextra)
- #causes trouble when compiling libusb1.0 on macintosh
- #comment out until mac ports libusb gets its act together
#ADD_DEFINITIONS(-pedantic)
#ADD_DEFINITIONS(-ansi)
#only export symbols that are declared to be part of the uhd api:
@@ -79,7 +77,6 @@ IF(MSVC)
ADD_DEFINITIONS(-DNOMINMAX) #disables stupidity and enables std::min and std::max
ADD_DEFINITIONS(-D_SCL_SECURE_NO_WARNINGS) #avoid warnings from boost::split
ADD_DEFINITIONS(-DBOOST_ALL_DYN_LINK) #setup boost auto-linking in msvc
- ADD_DEFINITIONS(/arch:SSE2 /G7) #processor optimization flags
ENDIF(MSVC)
########################################################################