summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-26 15:56:04 -0800
committerJosh Blum <josh@joshknows.com>2010-03-26 15:56:04 -0800
commit72927d983f1f84127e83bf2d80db6b8ee882bad7 (patch)
tree7b06abec256e6e2d555462a8e37a17218451d834 /host/CMakeLists.txt
parentd1e67602d21bcf97dbea28206659f3ee1146cf4a (diff)
downloaduhd-72927d983f1f84127e83bf2d80db6b8ee882bad7.tar.gz
uhd-72927d983f1f84127e83bf2d80db6b8ee882bad7.tar.bz2
uhd-72927d983f1f84127e83bf2d80db6b8ee882bad7.zip
library loading on windows, status message tweaks, warning tweaks
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 148ba2d00..05d782abe 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -64,10 +64,10 @@ IF(UNIX)
ENDIF(UNIX)
IF(WIN32)
- ADD_DEFINITIONS(-Dnot=! -Dand=&& -Dor=||) #logical operators
ADD_DEFINITIONS(-D_WIN32_WINNT=0x0501) #minimum version required is windows xp
ADD_DEFINITIONS(-DNOMINMAX) #disables stupidity and enables std::min and std::max
ADD_DEFINITIONS(-D_SCL_SECURE_NO_WARNINGS) #avoid warnings from boost::split
+ ADD_DEFINITIONS(-D_CRT_SECURE_NO_WARNINGS) #avoid warnings from std::getenv
ADD_DEFINITIONS(-DBOOST_ALL_DYN_LINK) #setup boost auto-linking in msvc
ENDIF(WIN32)