summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-22 09:50:35 +0000
committerJosh Blum <josh@joshknows.com>2010-03-22 09:50:35 +0000
commit6ba5135c96d81d23eafa4f0740ebbf113d8c798f (patch)
tree50dbe1ac4d36c1a00374718d478617dbb18cd2ef /host/CMakeLists.txt
parent10ee8022dd22f13f942d8bfeeca3b380224fff52 (diff)
parentd66efda608db9f6a1c2ab64659556b53810d87b7 (diff)
downloaduhd-6ba5135c96d81d23eafa4f0740ebbf113d8c798f.tar.gz
uhd-6ba5135c96d81d23eafa4f0740ebbf113d8c798f.tar.bz2
uhd-6ba5135c96d81d23eafa4f0740ebbf113d8c798f.zip
Merge branch 'master' of git@ettus.sourcerepo.com:ettus/uhd into u1e_uhd
Conflicts: host/include/uhd/usrp/dboard_id.hpp
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 60af3d0a1..2f5d03f7d 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -58,17 +58,22 @@ IF(UNIX)
UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-Wextra HAVE_WEXTRA)
UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-pedantic HAVE_PEDANTIC)
UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-ansi HAVE_ANSI)
+ #only export symbols that are declared to be part of the uhd api:
+ UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_HIDDEN)
ENDIF(UNIX)
IF(WIN32)
ADD_DEFINITIONS(-Dnot=! -Dand=&& -Dor=||) #logical operators
- ADD_DEFINITIONS(-D_WIN32_WINNT=0x0501) #as requested by vs
+ ADD_DEFINITIONS(-D_WIN32_WINNT=0x0501) #minimum version required is windows xp
ADD_DEFINITIONS(-DNOMINMAX) #disables stupidity and enables std::min and std::max
+ ADD_DEFINITIONS(-D_SCL_SECURE_NO_WARNINGS) #avoid warnings from boost::split
+ ADD_DEFINITIONS(-DBOOST_ALL_DYN_LINK) #setup boost auto-linking in msvc
ENDIF(WIN32)
########################################################################
# Setup Boost
########################################################################
+SET(Boost_ADDITIONAL_VERSIONS "1.42.0" "1.42")
FIND_PACKAGE(Boost 1.36 REQUIRED
date_time
filesystem