summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-05-14 17:09:10 -0700
committerJosh Blum <josh@joshknows.com>2011-05-14 17:09:10 -0700
commit29a0c916dfdc2f960761c1bebcccc53478abd30c (patch)
tree64c33a95200c78d8cd6ce2691e31f92e37e40dc8 /host/CMakeLists.txt
parent3ee0252b33086dda8463fe5b59603cb932589f6c (diff)
downloaduhd-29a0c916dfdc2f960761c1bebcccc53478abd30c.tar.gz
uhd-29a0c916dfdc2f960761c1bebcccc53478abd30c.tar.bz2
uhd-29a0c916dfdc2f960761c1bebcccc53478abd30c.zip
uhd: add gcc warning for sign comparison mismatch
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 6b342c2d3..1559bd6bf 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -70,6 +70,8 @@ SET(CMAKE_BUILD_TYPE "${CMAKE_BUILD_TYPE}" CACHE STRING "")
IF(CMAKE_COMPILER_IS_GNUCXX)
ADD_DEFINITIONS(-Wall)
ADD_DEFINITIONS(-Wextra)
+ ADD_DEFINITIONS(-Wsign-compare)
+ #ADD_DEFINITIONS(-Wconversion)
#ADD_DEFINITIONS(-pedantic)
#ADD_DEFINITIONS(-ansi)
IF(NOT WIN32)