summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-09-22 11:36:51 -0700
committerJosh Blum <josh@joshknows.com>2010-09-22 11:36:51 -0700
commit27cb282a29c0d9d67393f3f35548a5111359f1b0 (patch)
tree702f8390af1912d77c2b86d464809e592af51bfd /host/CMakeLists.txt
parent1b3b856f5a5d06628d4176071cad424a146433c9 (diff)
downloaduhd-27cb282a29c0d9d67393f3f35548a5111359f1b0.tar.gz
uhd-27cb282a29c0d9d67393f3f35548a5111359f1b0.tar.bz2
uhd-27cb282a29c0d9d67393f3f35548a5111359f1b0.zip
uhd: honor the LIB_SUFFIX option, added docs for LIB_SUFFIX and tweaked other docs
disabled -pedantic for now as well
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index ceea5d024..566bfd538 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -30,7 +30,7 @@ INCLUDE(${CMAKE_SOURCE_DIR}/config/CPack.cmake)
# Install Dirs
########################################################################
SET(RUNTIME_DIR bin)
-SET(LIBRARY_DIR lib)
+SET(LIBRARY_DIR lib${LIB_SUFFIX})
SET(INCLUDE_DIR include)
SET(PKG_DATA_DIR share/uhd)
SET(PKG_DOC_DIR share/doc/uhd)
@@ -61,7 +61,9 @@ ENDIF(NOT CMAKE_BUILD_TYPE)
IF(CMAKE_COMPILER_IS_GNUCXX)
ADD_DEFINITIONS(-Wall)
ADD_DEFINITIONS(-Wextra)
- ADD_DEFINITIONS(-pedantic)
+ #causes trouble when compiling libusb1.0 on macintosh
+ #comment out until mac ports libusb gets its act together
+ #ADD_DEFINITIONS(-pedantic)
ADD_DEFINITIONS(-ansi)
#only export symbols that are declared to be part of the uhd api:
UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_HIDDEN)