summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-03-11 09:29:31 -0800
committerJosh Blum <josh@joshknows.com>2011-03-11 09:29:31 -0800
commit2da8a0ae843de2035cd46a65a8780c4210d487d7 (patch)
tree4b4a119324e72383ac44553731e10a337cd8c5a0 /host/CMakeLists.txt
parent4dd34ae676eaed69538fe920f1d7c3b0cb9b8d82 (diff)
downloaduhd-2da8a0ae843de2035cd46a65a8780c4210d487d7.tar.gz
uhd-2da8a0ae843de2035cd46a65a8780c4210d487d7.tar.bz2
uhd-2da8a0ae843de2035cd46a65a8780c4210d487d7.zip
uhd: only specify BOOST_SP_USE_QUICK_ALLOCATOR for the lib, apps can be built without it
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index e4f272a76..4e7a4fe7b 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -62,10 +62,6 @@ IF(NOT CMAKE_BUILD_TYPE)
MESSAGE(STATUS "Build type not specified: defaulting to release.")
ENDIF(NOT CMAKE_BUILD_TYPE)
-#Creating a shared pointer itself has allocation overhead.
-#Define the quick allocator to reduce fast-path overhead.
-ADD_DEFINITIONS(-DBOOST_SP_USE_QUICK_ALLOCATOR)
-
IF(CMAKE_COMPILER_IS_GNUCXX)
ADD_DEFINITIONS(-Wall)
ADD_DEFINITIONS(-Wextra)