summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-07-16 10:16:21 -0700
committerJosh Blum <josh@joshknows.com>2010-07-16 10:16:21 -0700
commitbbf57e94e9f18b5f31a2ab784f97428898901492 (patch)
treed5682d97e352b68bfc8b858a753438854ba70742 /host/CMakeLists.txt
parent8171547b6cf8eaf95901f6f4fbc47c1720caf39a (diff)
downloaduhd-bbf57e94e9f18b5f31a2ab784f97428898901492.tar.gz
uhd-bbf57e94e9f18b5f31a2ab784f97428898901492.tar.bz2
uhd-bbf57e94e9f18b5f31a2ab784f97428898901492.zip
uhd: fix quotes for boost additional versions, restrict lib64 check to unix platforms
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index e26ec03d2..45e18993e 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -81,11 +81,11 @@ ENDIF(MSVC)
########################################################################
# Setup Boost
########################################################################
-IF(EXISTS "/usr/lib64")
+IF(UNIX AND EXISTS "/usr/lib64")
LIST(APPEND BOOST_LIBRARYDIR "/usr/lib64") #fedora 64-bit fix
-ENDIF(EXISTS "/usr/lib64")
+ENDIF(UNIX AND EXISTS "/usr/lib64")
-SET(Boost_ADDITIONAL_VERSIONS "1.42.0" "1.42 1.43.0" "1.43")
+SET(Boost_ADDITIONAL_VERSIONS "1.42.0" "1.42" "1.43.0" "1.43")
FIND_PACKAGE(Boost 1.36 REQUIRED COMPONENTS
date_time
filesystem