summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Foster <nick@nerdnetworks.org>2010-09-28 17:46:39 -0700
committerNick Foster <nick@nerdnetworks.org>2010-09-28 17:46:39 -0700
commit450abc5b213fc477ae0f2d648405a8b6a55a7b03 (patch)
tree01820d898ecd6541f988378413b4c55f16ebad6d /host/CMakeLists.txt
parent7cb95203f8d7173e3d7070d24f68358be67d0b29 (diff)
parentb70d4430d4a898fe99b54740a1c4821ed9a1077b (diff)
downloaduhd-450abc5b213fc477ae0f2d648405a8b6a55a7b03.tar.gz
uhd-450abc5b213fc477ae0f2d648405a8b6a55a7b03.tar.bz2
uhd-450abc5b213fc477ae0f2d648405a8b6a55a7b03.zip
Merge branch 'master' of ettus.sourcerepo.com:ettus/uhdpriv into tvrx_uhd
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index ceea5d024..566bfd538 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -30,7 +30,7 @@ INCLUDE(${CMAKE_SOURCE_DIR}/config/CPack.cmake)
# Install Dirs
########################################################################
SET(RUNTIME_DIR bin)
-SET(LIBRARY_DIR lib)
+SET(LIBRARY_DIR lib${LIB_SUFFIX})
SET(INCLUDE_DIR include)
SET(PKG_DATA_DIR share/uhd)
SET(PKG_DOC_DIR share/doc/uhd)
@@ -61,7 +61,9 @@ ENDIF(NOT CMAKE_BUILD_TYPE)
IF(CMAKE_COMPILER_IS_GNUCXX)
ADD_DEFINITIONS(-Wall)
ADD_DEFINITIONS(-Wextra)
- ADD_DEFINITIONS(-pedantic)
+ #causes trouble when compiling libusb1.0 on macintosh
+ #comment out until mac ports libusb gets its act together
+ #ADD_DEFINITIONS(-pedantic)
ADD_DEFINITIONS(-ansi)
#only export symbols that are declared to be part of the uhd api:
UHD_ADD_OPTIONAL_CXX_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_HIDDEN)