summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-06-07 15:10:37 -0700
committerJosh Blum <josh@joshknows.com>2010-06-07 15:10:37 -0700
commit11e2d407ce4a45da8c6981abfd34883cb9174840 (patch)
tree8f4353da0855ae7a15e223199e83e50646d0b2ed /host/CMakeLists.txt
parent0f4eff49c820a8d2ccb38e191604eb86c81b30af (diff)
downloaduhd-11e2d407ce4a45da8c6981abfd34883cb9174840.tar.gz
uhd-11e2d407ce4a45da8c6981abfd34883cb9174840.tar.bz2
uhd-11e2d407ce4a45da8c6981abfd34883cb9174840.zip
Created a common usrp dsp utils to handle register word calculations.
(also switched to boost endian define to avoid c compiler check)
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 57670fa6e..a8b89d6c5 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -16,7 +16,7 @@
#
CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-PROJECT(UHD)
+PROJECT(UHD CXX)
ENABLE_TESTING()
########################################################################
@@ -90,15 +90,6 @@ INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
########################################################################
-# Setup Endianess
-########################################################################
-INCLUDE(TestBigEndian)
-TEST_BIG_ENDIAN(HAVE_BIG_ENDIAN)
-IF(HAVE_BIG_ENDIAN)
- ADD_DEFINITIONS(-DHAVE_BIG_ENDIAN)
-ENDIF(HAVE_BIG_ENDIAN)
-
-########################################################################
# Create Uninstall Target
########################################################################
CONFIGURE_FILE(