summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-01-11 19:44:46 -0800
committerJosh Blum <josh@joshknows.com>2011-01-11 19:44:46 -0800
commit18defbd9d40a4c11a33025c8684f48fe51f102c5 (patch)
tree0108636abe7a42f1c3de22043e7ef230dec89cba /host/CMakeLists.txt
parent6c03f7e74bf7fcbfbcbc02de89aac9550097afc9 (diff)
downloaduhd-18defbd9d40a4c11a33025c8684f48fe51f102c5.tar.gz
uhd-18defbd9d40a4c11a33025c8684f48fe51f102c5.tar.bz2
uhd-18defbd9d40a4c11a33025c8684f48fe51f102c5.zip
uhd: add msvc stdint.h so we can use stdints typedefs normally like, fix in fw_common.h
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index f59cda23f..6a2b62a6d 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -74,6 +74,7 @@ IF(CMAKE_COMPILER_IS_GNUCXX)
ENDIF(CMAKE_COMPILER_IS_GNUCXX)
IF(MSVC)
+ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/msvc)
ADD_DEFINITIONS(-D_WIN32_WINNT=0x0501) #minimum version required is windows xp
ADD_DEFINITIONS(-DNOMINMAX) #disables stupidity and enables std::min and std::max
ADD_DEFINITIONS(-D_SCL_SECURE_NO_WARNINGS) #avoid warnings from boost::split