summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-03-25 15:04:23 -0700
committerJosh Blum <josh@joshknows.com>2011-03-25 15:04:23 -0700
commit2249acd9f97e969f619fa87cb206fc9392b9b5fe (patch)
tree5e63e918e3aad03512d565c9abc6cb0324c34ce5 /host/CMakeLists.txt
parent95b966a599c0030921dc6b530ca8c94633d905f6 (diff)
downloaduhd-2249acd9f97e969f619fa87cb206fc9392b9b5fe.tar.gz
uhd-2249acd9f97e969f619fa87cb206fc9392b9b5fe.tar.bz2
uhd-2249acd9f97e969f619fa87cb206fc9392b9b5fe.zip
uhd: work on mac osx packaging
Renamed README type files to have .txt extension (needed for CPACK_RESOURCE_FILE_*). Tweaks to the cpack setup on CPACK_RESOURCE_FILE_* and handling for when UHD_PACKAGE_MODE==AUTO. As of this commit, the mac packages do not contain the .dylib files (do not know why yet).
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 4160e8186..8516da401 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -163,9 +163,9 @@ INSTALL(
# Install Package Docs
########################################################################
INSTALL(FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/README
- ${CMAKE_CURRENT_SOURCE_DIR}/LICENSE
- ${CMAKE_CURRENT_SOURCE_DIR}/AUTHORS
+ ${CMAKE_CURRENT_SOURCE_DIR}/README.txt
+ ${CMAKE_CURRENT_SOURCE_DIR}/LICENSE.txt
+ ${CMAKE_CURRENT_SOURCE_DIR}/AUTHORS.txt
DESTINATION ${PKG_DOC_DIR}
COMPONENT libraries
)