aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorAshish Chaudhari <ashish@ettus.com>2015-04-30 18:02:02 -0700
committerAshish Chaudhari <ashish@ettus.com>2015-04-30 18:02:02 -0700
commitf2337d6fe0cca7337e0678d8f3ee31f657b608f2 (patch)
tree98c71da44375cc7c4a299e7ff1f2f70147526e8e /host/CMakeLists.txt
parenta7150e25f1ec5802963f44c5f748b211c6fcae8f (diff)
parentc6d0daaf034f3c1f20b8a0e6cd5c2555879760e2 (diff)
downloaduhd-f2337d6fe0cca7337e0678d8f3ee31f657b608f2.tar.gz
uhd-f2337d6fe0cca7337e0678d8f3ee31f657b608f2.tar.bz2
uhd-f2337d6fe0cca7337e0678d8f3ee31f657b608f2.zip
Merge branch 'master' into vivado
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt19
1 files changed, 16 insertions, 3 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 8dddb6552..75635e415 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -24,7 +24,7 @@
# Project setup
########################################################################
CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-PROJECT(UHD CXX)
+PROJECT(UHD CXX C)
ENABLE_TESTING()
#make sure our local CMake Modules path comes first
@@ -284,8 +284,8 @@ UHD_INSTALL(FILES
#{{{IMG_SECTION
# This section is written automatically by /images/create_imgs_package.py
# Any manual changes in here will be overwritten.
-SET(UHD_IMAGES_MD5SUM "37d4899e320809951149c3670fb054ee")
-SET(UHD_IMAGES_DOWNLOAD_SRC "uhd-images_003.009.git-139-g3e3e236a.zip")
+SET(UHD_IMAGES_MD5SUM "4b30c563530a3339a1a1510762afe555")
+SET(UHD_IMAGES_DOWNLOAD_SRC "uhd-images_003.009.git-166-ged632e6a.zip")
#}}}
########################################################################
@@ -297,6 +297,19 @@ LIBUHD_REGISTER_COMPONENT("Utils" ENABLE_UTILS ON "ENABLE_LIBUHD" OFF)
LIBUHD_REGISTER_COMPONENT("Tests" ENABLE_TESTS ON "ENABLE_LIBUHD" OFF)
########################################################################
+# Check for fpga-src submodule
+########################################################################
+SET(HAS_FPGA_SUBMODULE FALSE)
+EXECUTE_PROCESS(
+ COMMAND ${PYTHON_EXECUTABLE} -c "import os; print os.path.abspath(os.path.join('${CMAKE_SOURCE_DIR}', '..', 'fpga-src'))"
+ OUTPUT_VARIABLE FPGA_SUBMODULE_DIR OUTPUT_STRIP_TRAILING_WHITESPACE
+)
+message(STATUS ${FPGA_SUBMODULE_DIR})
+IF(EXISTS "${FPGA_SUBMODULE_DIR}/docs/fpga.md")
+ SET(HAS_FPGA_SUBMODULE TRUE)
+ENDIF(EXISTS "${FPGA_SUBMODULE_DIR}/docs/fpga.md")
+
+########################################################################
# Add the subdirectories
########################################################################
ADD_SUBDIRECTORY(docs)