aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Stapleton <brent.stapleton@ettus.com>2018-08-01 15:25:11 -0700
committerMartin Braun <martin.braun@ettus.com>2018-08-01 16:20:24 -0700
commitf038a0284867faa65eedfd0d39ce0ecb8b8647f5 (patch)
treef2f1d3f449ec4457ad32943f3dc8d025436cfc3d /host/CMakeLists.txt
parent47f12a1e9c75bf05fcb06fbc885f9b93848188a9 (diff)
downloaduhd-f038a0284867faa65eedfd0d39ce0ecb8b8647f5.tar.gz
uhd-f038a0284867faa65eedfd0d39ce0ecb8b8647f5.tar.bz2
uhd-f038a0284867faa65eedfd0d39ce0ecb8b8647f5.zip
python: Enable Python API on non-Windows
On non-Windows platforms, enable the Python API by default in CMake. Enabling the Python API in Windows causes build failures- that is, we currently can't detect if the requirements are met in the Windows build system. Because of that, we'll leave it disabled by default for now.
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 281c55c5d..00b9102e4 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -430,7 +430,11 @@ UHD_INSTALL(FILES
########################################################################
LIBUHD_REGISTER_COMPONENT("LibUHD" ENABLE_LIBUHD ON "Boost_FOUND;HAVE_PYTHON_PLAT_MIN_VERSION;HAVE_PYTHON_MODULE_MAKO" OFF ON)
LIBUHD_REGISTER_COMPONENT("LibUHD - C API" ENABLE_C_API ON "ENABLE_LIBUHD" OFF OFF)
-LIBUHD_REGISTER_COMPONENT("LibUHD - Python API" ENABLE_PYTHON_API OFF "ENABLE_LIBUHD;BOOST_PYTHON_FOUND;HAVE_PYTHON_MODULE_NUMPY;PythonLibs_FOUND" OFF OFF)
+IF(WIN32)
+ LIBUHD_REGISTER_COMPONENT("LibUHD - Python API" ENABLE_PYTHON_API OFF "ENABLE_LIBUHD;BOOST_PYTHON_FOUND;HAVE_PYTHON_MODULE_NUMPY;PythonLibs_FOUND" OFF OFF)
+ELSE()
+ LIBUHD_REGISTER_COMPONENT("LibUHD - Python API" ENABLE_PYTHON_API ON "ENABLE_LIBUHD;BOOST_PYTHON_FOUND;HAVE_PYTHON_MODULE_NUMPY;PythonLibs_FOUND" OFF OFF)
+ENDIF(WIN32)
LIBUHD_REGISTER_COMPONENT("Examples" ENABLE_EXAMPLES ON "ENABLE_LIBUHD" OFF OFF)
LIBUHD_REGISTER_COMPONENT("Utils" ENABLE_UTILS ON "ENABLE_LIBUHD" OFF OFF)
LIBUHD_REGISTER_COMPONENT("Tests" ENABLE_TESTS ON "ENABLE_LIBUHD" OFF OFF)