aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Hilburn <ben.hilburn@ettus.com>2015-01-28 13:23:42 -0800
committerBen Hilburn <ben.hilburn@ettus.com>2015-01-28 13:23:42 -0800
commitb92662d5780f3a2d872e5ab96efc0760cce1fe53 (patch)
tree2a4b03ad89ea68619010ecee0115c702fb2354d8 /host/CMakeLists.txt
parentebe7169dcecd1b6899734cefdf5771612067fd48 (diff)
parentdb3fac73beb30ceaaf6a275d9668a38af3b839f5 (diff)
downloaduhd-b92662d5780f3a2d872e5ab96efc0760cce1fe53.tar.gz
uhd-b92662d5780f3a2d872e5ab96efc0760cce1fe53.tar.bz2
uhd-b92662d5780f3a2d872e5ab96efc0760cce1fe53.zip
Merge branch 'maint' into master
Resolved Conflicts: host/docs/usrp_e3x0.dox host/include/uhd/utils/paths.hpp host/lib/transport/nirio/nifpga_lvbitx.cpp host/lib/usrp/b200/b200_impl.cpp host/lib/utils/paths.cpp
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt22
1 files changed, 21 insertions, 1 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 0f756ef2d..960e321ff 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -60,6 +60,26 @@ SET(PKG_DOC_DIR share/doc/uhd)
SET(PKG_MAN_DIR share/man/man1)
########################################################################
+# UHD Image Directories
+########################################################################
+IF(NOT DEFINED UHD_IMAGES_DIR)
+ IF(DEFINED FPGA_IMAGES_DIR)
+ SET(UHD_IMAGES_DIR ${FPGA_IMAGES_DIR})
+ ELSE(DEFINED FPGA_IMAGES_DIR)
+ FILE(TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/share/uhd/images using_images_dir)
+ SET(UHD_IMAGES_DIR ${using_images_dir})
+ ENDIF(DEFINED FPGA_IMAGES_DIR)
+ENDIF(NOT DEFINED UHD_IMAGES_DIR)
+
+OPTION(UHD_IMAGES_DIR "Path to installed UHD image binaries.")
+MESSAGE( STATUS "Using UHD Images Directory: ${UHD_IMAGES_DIR}" )
+ADD_DEFINITIONS(-DUHD_IMAGES_DIR=${UHD_IMAGES_DIR})
+
+IF(DEFINED USE_NIUSRP_WINREG_KEY)
+ ADD_DEFINITIONS(-DUSE_NIUSRP_WINREG_KEY)
+ENDIF(DEFINED USE_NIUSRP_WINREG_KEY)
+
+########################################################################
# Local Include Dir
########################################################################
INCLUDE_DIRECTORIES(${CMAKE_BINARY_DIR}/include)
@@ -378,7 +398,7 @@ UHD_INSTALL(
)
########################################################################
-# Handle pre-built images
+# Handle pre-built UHD Images meant for installation
########################################################################
IF(DEFINED UHD_IMAGES_DIR AND EXISTS "${UHD_IMAGES_DIR}")
FILE(GLOB_RECURSE _image_files "${UHD_IMAGES_DIR}/*")