aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2015-07-07 15:41:50 -0700
committerMartin Braun <martin.braun@ettus.com>2015-07-14 14:51:32 -0700
commit8057c17458bd32856842299df58662e784423d8f (patch)
treed9edfe04cd3df7f994328ab76dc6840c6bdedc79 /host/CMakeLists.txt
parent4b1034b29e57a0b405fc89de4602819a4b8cc970 (diff)
downloaduhd-8057c17458bd32856842299df58662e784423d8f.tar.gz
uhd-8057c17458bd32856842299df58662e784423d8f.tar.bz2
uhd-8057c17458bd32856842299df58662e784423d8f.zip
build: Python 3 compatibility for build scripts
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 63fbf6032..def2bd237 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -301,7 +301,7 @@ LIBUHD_REGISTER_COMPONENT("Tests" ENABLE_TESTS ON "ENABLE_LIBUHD" OFF)
########################################################################
SET(HAS_FPGA_SUBMODULE FALSE)
EXECUTE_PROCESS(
- COMMAND ${PYTHON_EXECUTABLE} -c "import os; print os.path.abspath(os.path.join('${CMAKE_SOURCE_DIR}', '..', 'fpga-src'))"
+ COMMAND ${PYTHON_EXECUTABLE} -c "import os; print(os.path.abspath(os.path.join('${CMAKE_SOURCE_DIR}', '..', 'fpga-src')))"
OUTPUT_VARIABLE FPGA_SUBMODULE_DIR
OUTPUT_STRIP_TRAILING_WHITESPACE
)