aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-08-20 10:00:47 -0700
committerMartin Braun <martin.braun@ettus.com>2019-11-26 12:16:25 -0800
commit7d69dcdcc318ccdf87038b732acbf2bf7c087b60 (patch)
tree8179f2f4a14be591d7c856f77f13687b45f9a454 /host/CMakeLists.txt
parent1ac6e6f56100a7e8186481ab0715937759f52737 (diff)
downloaduhd-7d69dcdcc318ccdf87038b732acbf2bf7c087b60.tar.gz
uhd-7d69dcdcc318ccdf87038b732acbf2bf7c087b60.tar.bz2
uhd-7d69dcdcc318ccdf87038b732acbf2bf7c087b60.zip
Remove proto-RFNoC files
This commit removes all files and parts of files that are used by proto-RFNoC only. uhd: Fix include CMakeLists.txt, add missing files
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 17af21824..53e5cba7e 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -301,8 +301,6 @@ link_directories(${Boost_LIBRARY_DIRS})
########################################################################
# Additional settings for build environment
########################################################################
-# Note: RFNoC never gets fully disabled, but the public APIs do
-set(ENABLE_RFNOC ON CACHE BOOL "Export RFNoC includes and symbols")
include(UHDGlobalDefs)
include(UHDLog)
@@ -470,12 +468,7 @@ endforeach(Boost_Comp)
if(ENABLE_USB)
list(APPEND UHD_LINK_LIST_STATIC "usb-1.0")
endif(ENABLE_USB)
-# UHDConfig.cmake also needs UHD_RFNOC_FOUND
-if(ENABLE_RFNOC)
- set(UHD_RFNOC_FOUND "TRUE")
-else()
- set(UHD_RFNOC_FOUND "FALSE")
-endif(ENABLE_RFNOC)
+set(UHD_RFNOC_FOUND "TRUE")
configure_file(
${CMAKE_SOURCE_DIR}/cmake/Modules/UHDConfigVersion.cmake.in