aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authormattprost <matt.prost@ni.com>2022-04-29 14:47:09 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2022-06-10 13:24:04 -0500
commit72e6df51de5a766889fedcb9970dedd7fcfda6e8 (patch)
treed16c5a7d1b27710e740775752293c12b62e77ab3 /host/CMakeLists.txt
parentcb8fa61a5bcc576224ab8afa80ed712c31ddd629 (diff)
downloaduhd-72e6df51de5a766889fedcb9970dedd7fcfda6e8.tar.gz
uhd-72e6df51de5a766889fedcb9970dedd7fcfda6e8.tar.bz2
uhd-72e6df51de5a766889fedcb9970dedd7fcfda6e8.zip
cmake: Add support for fedora rpm versioning
Adds cmake option for replacing dashes in the UHD Component version with underscores. This is necessary as Fedora package management is now enforcing the format <Package>-<Version>-<Release> for all rpm builds, so dashes in the UHD_VERSION from dev branches is not supported. Signed-off-by: mattprost <matt.prost@ni.com>
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 3a523ad5d..99dd17fe7 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -98,6 +98,7 @@ endif()
# Packaging Variables
########################################################################
+option(UNDERSCORE_UHD_VERSION "Replace dashes in uhd version with underscores" OFF)
set(LIBUHD_PKG ${LIBUHD_PKG} CACHE BOOL "Build Debian libuhd003 package")
set(LIBUHDDEV_PKG ${LIBUHDDEV_PKG} CACHE BOOL "Build Debian libuhd-dev package")
set(UHDHOST_PKG ${UHDPOST_PKG} CACHE BOOL "Build Debian uhd-host package")