aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2020-02-04 14:37:19 -0800
committeratrnati <54334261+atrnati@users.noreply.github.com>2020-02-06 08:45:27 -0600
commit6f96639d25e3c6103048aa9809420e897970def0 (patch)
tree2dfe21a3b9cad76631008ab0703e0854b9c67e92 /host/CMakeLists.txt
parent401fcd11be0cab028a619c9bc4a75fe6aa856369 (diff)
downloaduhd-6f96639d25e3c6103048aa9809420e897970def0.tar.gz
uhd-6f96639d25e3c6103048aa9809420e897970def0.tar.bz2
uhd-6f96639d25e3c6103048aa9809420e897970def0.zip
cmake/doxygen: Fix FPGA manual post-FPGA-merge
While merging the FPGA code into the UHD codebase, the manual building process was not modified, resulting in either a link to the website instead of building the FPGA manual as part of the rest, or by using a residual submodule.
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt15
1 files changed, 0 insertions, 15 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 55110e12a..95f110e9e 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -375,21 +375,6 @@ LIBUHD_REGISTER_COMPONENT("Utils" ENABLE_UTILS ON "ENABLE_LIBUHD" OFF OFF)
LIBUHD_REGISTER_COMPONENT("Tests" ENABLE_TESTS ON "ENABLE_LIBUHD" OFF OFF)
########################################################################
-# Check for fpga-src submodule
-########################################################################
-set(HAS_FPGA_SUBMODULE FALSE)
-execute_process(
- COMMAND ${PYTHON_EXECUTABLE} -c "import os; print(os.path.abspath(os.path.join('${CMAKE_SOURCE_DIR}', '..', 'fpga-src')))"
- OUTPUT_VARIABLE FPGA_SUBMODULE_DIR
- OUTPUT_STRIP_TRAILING_WHITESPACE
-)
-if(EXISTS "${FPGA_SUBMODULE_DIR}/docs/fpga.md")
- set(HAS_FPGA_SUBMODULE TRUE)
- message(STATUS "")
- message(STATUS "Found FPGA submodule: ${FPGA_SUBMODULE_DIR}")
-endif(EXISTS "${FPGA_SUBMODULE_DIR}/docs/fpga.md")
-
-########################################################################
# Add the subdirectories
########################################################################
if(ENABLE_LIBUHD)