aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Koo <steven.koo@ni.com>2021-12-16 17:01:46 -0600
committerAaron Rossetto <aaron.rossetto@ni.com>2022-01-06 15:10:53 -0600
commit2ff98cf43c801bc24d37fb9addae3dd77dac19ff (patch)
treed47c640fb4e69463157859478246eec7718cae91 /host/CMakeLists.txt
parent5e40438ee9834025dc7065c686ab34815458e1a4 (diff)
downloaduhd-2ff98cf43c801bc24d37fb9addae3dd77dac19ff.tar.gz
uhd-2ff98cf43c801bc24d37fb9addae3dd77dac19ff.tar.bz2
uhd-2ff98cf43c801bc24d37fb9addae3dd77dac19ff.zip
cmake: Set debug to -Og for Clang builds
This fails to link otherwise on macOS Signed-off-by: Steven Koo <steven.koo@ni.com>
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index fcf9feed3..0a3bf3d83 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -79,6 +79,7 @@ elseif(${CMAKE_CXX_COMPILER_ID} MATCHES "Clang")
else()
message(WARNING "\nCannot determine the version of the compiler selected to build UHD (${APPLE_STR}Clang : ${CMAKE_CXX_COMPILER}). This build may or not work. We highly recommend using Apple Clang version ${APPLECLANG_MIN_VERSION} or more recent, or Clang version ${CLANG_MIN_VERSION} or more recent.")
endif()
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Og")
elseif(MSVC)
if(${MSVC_VERSION} VERSION_LESS ${MSVC_MIN_VERSION})
message(FATAL_ERROR "\nMSVC version is less than the required minimum. Required: ${MSVC_MIN_VERSION_READABLE}")